Android Studio dice di utilizzare Gradle 1.10 – ma la nuova versione è 1.12?

L'errore:

The project is using an unsupported version of Gradle. Please use version 1.10. My `gradle.build` file says this: dependencies { classpath 'com.android.tools.build:gradle:0.12.+' } 

Per quanto ne so, la linea di cui sopra è corretta. Il mio file gradle-wrapper dice:

  • Come fermare la connessione HttpURLConnection su Android
  • creare Bitmap da byteArray in android
  • Elevazione CoordinatorLayout e AppBarLayout
  • Come get / rilevare la dimensione dello schermo in Xamarin.Forms?
  • impostato l'orientamento della videocamera android iniziata con l'intenzione ACTION_IMAGE_CAPTURE
  • Modo universale per scrivere sulla scheda SD esterna su Android
  •  distributionUrl=http\://services.gradle.org/distributions/gradle-1.12-all.zip 

    Ciò è accaduto quando ho scaricato il nuovo Android Studio beta (v.8) e ho provato ad importre un'applicazione che avevo, quello che suppongo è una vecchia versione di Gradle.

    Inoltre, quando ho colpito " Fix Gradle Wrapper and re-import project ", non succede niente.

  • Binding OxyPlot tramite MVVMCross in Xamarin.Android
  • Android: Come configurare la versione più recente di FFMPEG in studio Android?
  • Avere il problema su Real Device utilizzando l'image vettoriale in android. SVG-Android
  • Un noto messaggio di spinta ricevuto all'avvio dell'app
  • EGL_BAD_MATCH con Droid / Droid 2
  • Come serializzare un object e salvarlo in un file in Android?
  • 3 Solutions collect form web for “Android Studio dice di utilizzare Gradle 1.10 – ma la nuova versione è 1.12?”

    Se si desidera modificare il wrapper gradle in una versione inferiore, è necessario modificare la distribuzioneUrl

     distributionUrl=http\://services.gradle.org/distributions/gradle-1.10-all.zip 

    e quindi eseguire nuovamente l'attività del wrapper. Se non è sufficiente eliminare le cartelle .gradle e gradle ei file gradlew e gradlew.bat . Il rerun wrapper e lui scarica gralde 1.10

    Poiché gradle ha avuto alcune importnti modifiche di api dalla versione 1.10 e 1.12 non è ansible build alcun progetto con una versione più alta, quindi i plugin vengono costruiti. Quindi, se il plugin android è costruito con gradle 1.10 è necessario utilizzare la stessa versione

    Errore: "Gradel versione 1.10 è richiesta. Versione corrente è 2,0"

    Perché è mostrato: Tentativo di creare un progetto Android che richiede la versione 1.10 di Gradle mentre utilizza la versione 2.0 come nativa.

    Cosa si deve fare per risolvere questo problema: Aggiornare la versione gradle all'interno del file build.gradle

     dependencies { classpath 'com.android.tools.build:gradle:0.12.2+' } 

    sostituendolo con

     dependencies { classpath 'com.android.tools.build:gradle:1.0.+' } 

    C'è una differenza tra la versione di Gradle e la versione di Gradle Android Plugin (0.12. +).
    Sembra che tu abbia bisogno di Gradle versione 1.10, non credo che le versioni successive siano supponate dal plugin di Gradle Android ancora. In each caso, penso di assicurarmi che utilizzi la versione Gradley 1.10 risolverà questo problema.

    L'Android è un fan Android di Google, tutto su telefoni Android, Android Wear, Android Dev e applicazioni Android Games e così via.