Tag: android gradle

Mancata costruzione di Gradle

Il mio progetto si compila ed esegue bene nella modalità di debug, ma quando provo a generare un apk firmato, si verificano errori. Questo appare nel registro dei messaggi: :app:proguardRelease Warning:android.support.v4.app.DialogFragment: can't find referenced class android.support.v4.app.DialogFragment$DialogStyle Warning:android.support.v4.app.FragmentTransaction: can't find referenced class android.support.v4.app.FragmentTransaction$Transit Warning:android.support.v4.view.ViewCompat: can't find referenced class android.support.v4.view.ViewCompat$ResolvedLayoutDirectionMode Warning:android.support.v4.view.ViewCompat: can't find referenced class android.support.v4.view.ViewCompat$LayoutDirectionMode Warning:android.support.v4.view.ViewCompat: […]

Android – Libreria di supporto di Renderscript – Errore durante il caricamento della libreria RS jni

Sto cercando di includere la libreria di supporto Renderscript nel mio progetto. Ho il seguente errore. android.support.v8.renderscript.RSRuntimeException: Error loading RS jni library: java.lang.UnsatisfiedLinkError: Couldn't load rsjni: findLibrary returned null Non sto utilizzando file di jars di Renderscript, sto tentando di utilizzarlo tramite Gradle. Ecco i miei file Gradle.build LIVELLO TOP buildscript { repositories { jcenter() […]

Perché Android Gradle preDexDebug "La fonte e la destinazione devono essere diversi" la costruzione non è rioutput?

Ho un'applicazione Android creata con Android Studio 0.8.1 e affrontare il problema: Error:Execution failed for task ':app:preDexDebug'. > java.lang.IllegalArgumentException: Source C:\Users\mfedorov\AndroidStudioProjects\EPOS2\app\build\intermediates\pre-dexed\debug\mate-api-0.0.1-SNAPSHOT-0ef7e3259aeaf19202f545da97dc6b1ae2502c9a.jar and destination C:\Users\mfedorov.ALTIUS-PLUS\AndroidStudioProjects\EPOS2\app\build\intermediates\pre-dexed\debug\mate-api-0.0.1-SNAPSHOT-0ef7e3259aeaf19202f545da97dc6b1ae2502c9a.jar must be different Ecco il mio contenuto di file build.gradle (la parte che ho cambiato, il resto è l'impostazione predefinita) configurations.all { // check for updates every build resolutionStrategy.cacheChangingModulesFor 0, 'seconds' […]

com.android.build.api.transform.TransformException: com.android.builder.packaging.DuplicateFileException: file duplicati

Io uso la versione android studio 2.0. Io uso la gradella per build il programma, prendi questa domanda: So che questa domanda nello studio Android 0.7version ha la stessa domanda. Vedo i file duplicati Link copiati (Android Studio 0.4.0) Ma seguo questo modo: Ma questo metodo non funziona per me! Potresti aiutarmi? Ti sto aspettando!

Come funziona la nuova applicazioneId in build.gradle?

Google ha rilasciato la versione 0.11 del plugin di Android Gradle. Le note di rilascio contengono le seguenti informazioni: Una delle modifiche visibili dall'utente in 0.11 è che abbiamo deprecato le impostazioni packageName e packageNameSuffix e le abbiamo rinominate in applicationId e applicationIdSuffix. Lo scopo di questo è quello di rendere chiaro che questo ID […]

Studio Android java.exe finito con valore di output non zero

Ho passato il valore di output nullo non zero, relativo alla questione multidex, ma ora ho ricevuto un valore di output non zero. Studio Messaggio: Information:Gradle: Executing tasks: [:emoticons_lib_proj:assembleDebug, :myProject_Developement:assembleDebug] Information:5/27/2015 5:56 PM – Compilation completed with 1 error and 0 warnings in 5m 58s 77ms Error:Gradle: Execution failed for task ':myProject_Developement:dexDebug'. com.android.ide.common.process.ProcessException: org.gradle.process.internal.ExecException: Processo […]

Causa: java.lang.NoClassDefFoundError: class non trovata utilizzando il loader di class di avvio; nessuna traccia disponibile

Ho provato a utilizzare okhttp e picasso (a seguito di questa risposta ) per la memorizzazione in dischetto di immagini che stavo scaricando da storage di firebad.Now l'applicazione fornisce eccezioni e crashes.I ho visto questi post post 1 , post 2 ma nessuna soluzione pertinente è found.i anche ha cercato di pulire e ribuild il […]

Gradle esclude arm64 libs

Ho un'applicazione che comprende due librerie, in cui entrambi hanno dependencies dalle biblioteche natali. Entrambi sono inclusi con gradel, quindi la struttura sembra così: MyApp – Libary1 — x86, armeabi native libs – Library2 — Library3 — x86, armeabi, arm64-v8a Voglio rimuovere il supporto arm64 come avrei bisogno anche di * .so per Library1, che […]

Errore di asserzione in Android Studio quando si cerca di compilare il progetto di lavoro

Mentre stavo cercando di build il mio progetto di lavoro nell'aggiornamento Android Studio (0.3.6), ho ricevuto il messaggio di errore di seguito. Funziona bene quando costruisco tramite CLI. java.lang.AssertionError at com.android.tools.idea.gradle.compiler.AndroidGradleBuildProcessParametersProvider.getVMArguments(AndroidGradleBuildProcessParametersProvider.java:101) at com.intellij.compiler.server.BuildManager.launchBuildProcess(BuildManager.java:921) at com.intellij.compiler.server.BuildManager.access$1900(BuildManager.java:121) at com.intellij.compiler.server.BuildManager$11$2.run(BuildManager.java:666) at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471) at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334) at java.util.concurrent.FutureTask.run(FutureTask.java:166) at com.intellij.util.concurrency.BoundedTaskExecutor$1.run(BoundedTaskExecutor.java:37) at com.intellij.openapi.application.impl.ApplicationImpl$8.run(ApplicationImpl.java:435) at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471) at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334) at java.util.concurrent.FutureTask.run(FutureTask.java:166) at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) […]

Android Studio 3.0 Beta 1: Imansible risolvere: com.android.support:multidex:1.0.2

Dopo la migrazione da Android Studio 3.0 (Canary 5) a Android Studio 3.0 (Beta 1) e spostandosi all'ultimo gradle, vale a dire 'com.android.tools.build:gradle:3.0.0-beta1' Quando provo a gradelare la sincronizzazione, errore indica di seguito. Failed to resolve: com.android.support:multidex:1.0.2 Failed to resolve: com.android.support:multidex-instrumentation:1.0.2 Controllo su Android Studio 3.0 Canary 9 – Imansible risolvere i pacchetti , non […]

L'Android è un fan Android di Google, tutto su telefoni Android, Android Wear, Android Dev e applicazioni Android Games e così via.