Tag: android studio

Errore: Imansible trovare o caricare la class principale org.gradle.wrapper.GradleWrapperMain

Il mio build.gradle per un'applicazione Android è diventato molto lungo. Condiviso su questo plugin chiamato gradle-lint-plugin e configurato correttamente. Nella sua documentazione dice Esegui ./gradlew fixGradleLint per risolvere automaticamente i tuoi script di build ma Error: Could not find or load main class org.gradle.wrapper.GradleWrapperMain che ottengo Error: Could not find or load main class org.gradle.wrapper.GradleWrapperMain […]

Tutorial Google Android – non compilazione

Ho fatto tutto quanto descritto in questo tutorial: google android basic tutorial e nonostante tutto è fatto come descritto, il codice rifiuta di compilare con 3 errori. Sembra che i ragazzi che scrivano il turorial dimenticano di menzionare quali sono quelle cose e where / come li definisco. Gli errori che ottengo: Error:(24, 68) error: […]

Ridimensiona l'image SVG all'interno della vista

Ho un FloatingActionButton con un'image SVG legata alla sua properties; src. Ma non visualizza la dimensione che mi serve, come ridimensionarla per mostrare l'image più grande? Ecco il mio disegni: <vector xmlns:android="http://schemas.android.com/apk/res/android" android:width="24dp" android:height="24dp" android:viewportWidth="24.0" android:viewportHeight="24.0"> <path android:fillColor="#ffffff" android:pathData="M19,13h-6v6h-2v-6H5v-2h6V5h2v6h6v2z"/> E qui è la mia opinione: <android.support.design.widget.FloatingActionButton android:id="@+id/fab" android:layout_width="wrap_content" android:layout_height="wrap_content" android:layout_gravity="bottom|end" android:layout_margin="@dimen/fab_margin" android:src="@drawable/ic_add_24dp" />

Disegno disegnabile nell'elenco di livelli reso in modo errato per le API inferiori a 23

Ieri, ho commutato a Android Studio versione 2.1.3. Oggi ho riaperto uno dei miei progetti e ho cercato di aggiungere alcuni disegni di liste di livello per l'utilizzo con un ImageView . Ad esempio, questo: <layer-list xmlns:android="http://schemas.android.com/apk/res/android"> <item android:width="80px" android:height="80px" android:top="0px" android:left="0px" android:right="0px" android:bottom="0px"> <shape android:shape="rectangle"> <solid android:color="@color/deep_orange"/> </shape> </item> <item android:width="60px" android:height="60px" android:top="10px" android:left="10px" […]

Android Studio non riesce – non support la versione minore 51.0 non supportta

Fino a ieri il mio Android Studio stava funzionando bene e mi ha aiutato a creare applicazioni. Ma oggi, ha cominciato a dare errore di errore di Gradle che ha dichiarato di non supportre la versione principale minima 51.0 e mi ha chiesto di configurare la gradella. Ho lo stesso errore se cerco di importre […]

Android Studio Imansible risolvere import di fragmentActivity e ViewPager

Segue l'esercitazione di sviluppare tabs in grado di scorrere. Quando importi: import android.support.v4.app.FragmentActivity; import android.support.v4.view.ViewPager; Android Studio mi mostra non riesce a risolvere il simbolo "ViewPager" e "FragmentActivity". Come risolvere questo problema? Grazie. Di seguito è riportto l'integer codice del mio progetto. import android.app.ActionBar; import android.app.ActionBar.Tab; import android.app.FragmentTransaction; import android.os.Bundle; import android.support.v4.app.FragmentActivity; import android.support.v4.view.ViewPager; public […]

AppCompatActivity non è assegnabile all'attività

Dopo un anno di codifica in android e tutto funziona perfettamente fino a ieri. Oggi ho trovato qualcosa di veramente strano dopo l'aggiornamento a gradle 3 alpha 2 e studio 3 build 2. Questa è la dichiarazione di una delle attività che lanciano errori: Questo è il codice attività: Che c'è? EDIT dipendenza appcompat: compile […]

Dopo l'aggiornamento a Android Studio 2.0 da 1.5, l'evidenziazione della syntax ndk non funziona o potrebbe essere interrotta

L'evidenziazione della syntax per il codice C / C ++ nella window dell'editor funzionava bene in AS 1.5. Ma dopo l'aggiornamento da AS 1.5 a 2.0, non funziona anche con il progetto HelloJNI. Provato con le impostazioni salvate, ripristinate le impostazioni predefinite e anche con il download e l'installazione automatica di AS 2.0 ma nulla […]

content_main.xml vs activity_main.xml

Ho recentemente aggiornato lo studio android a 1,4 e ho notato che ora esiste un content_main.xml e un activity_main.xml . Sembra che content_main si occupa di ciò che entra nell'app e activity_main si occupa del layout / visualizzazione dei widget da content_main, non so se questo sia corretto? Sarebbe anche ansible che chiunque spiega perché […]

Libreria di supporto di Android Build error v26.XX Build: attributo "font" già definito

Sto provando ad aggiornare dalla versione 25.3.1 alla versione 26.XX della libreria di supporto, ma each volta che costruisco il progetto usando la versione più recente, ottengo questo errore: Error:(357) Attribute "font" already defined with incompatible format. Error:(343) Original attribute defined here. Error:java.util.concurrent.ExecutionException: com.android.ide.common.process.ProcessException: Error while executing process /Users/johnsmith/Library/Android/sdk/build-tools/26.0.1/aapt with arguments {package -f –no-crunch -I […]

L'Android è un fan Android di Google, tutto su telefoni Android, Android Wear, Android Dev e applicazioni Android Games e così via.