Tag: android studio

La fusione manifesta non è rioutput: uses-sdk: minSdkVersion 14

Dal download dell'ultimo SDK e dall'installazione di Android Studio, il mio progetto non riesce a build. Ho il seguente messaggio: Error:Gradle: Execution failed for task ':SampleProject:processProdDebugManifest'. > Manifest merger failed : uses-sdk:minSdkVersion 14 cannot be smaller than version L declared in library com.android.support:support-v4:21.0.0-rc1

Come utilizzare opencv in android studio utilizzando strumento build gradle?

Voglio usare lo studio Android per sviluppare un'applicazione utilizzando lo strumento di costruzione di gradle. Non posso inserire il repo opencv e la libreria su build.gradle. Il mio file gradle è come sotto: buildscript { repositories { mavenCentral() } dependencies { classpath 'com.android.tools.build:gradle:0.5.+' } } apply plugin: 'android' repositories { mavenCentral() } dependencies { compile […]

Includi la biblioteca .so in apk in studio android

Sto cercando le mie mani per sviluppare una semplice applicazione android in cui sto cercando di utilizzare sqlcipher , che utilizza le biblioteche .so internamente. Ho letto la documentazione su come utilizzare sqlcipher con app android . Ho seguito i passi e compila senza alcun errore. Ma, a rotazione, lancia UnsatisfiedLinkError . Andando in giro […]

AppCompat v7 r21 restituisce l'errore in values.xml?

Sto utilizzando Android Studio e quando aggiungo il compile "com.android.support:appcompat-v7:21.0.0" al mio file Gradle, ho una quantità di errori: C:\Users\WindowsSucks\AndroidStudioProjects\MMMeds\app\build\intermediates\exploded-aar\com.android.support\appcompat-v7\21.0.0\res\values-v11\values.xml Error:(36, 21) No resource found that matches the given name: attr 'android:actionModeShareDrawable'. Error:(36, 21) No resource found that matches the given name: attr 'android:actionModeShareDrawable'. Error:(36, 21) No resource found that matches the given name: attr […]

Studio Android, gradle e NDK

Sono molto nuovo a tutto questo gradle e supporto per Android Studio. Sono riuscito a convertire il mio progetto android a gradual utilizzando l'opzione di esportzione. Ma io sto cercando qualche documentazione o punto di partenza per integrare la NDK nel process di build gradle. Se ansible, ho anche bisogno di una sorta di "dopo" […]

È ansible dichiarare una variabile in Gradle utilizzabile in Java?

È ansible dichiarare una variabile in Gradle utilizzabile in Java? Fondamentalmente vorrei dichiarare qualche vars nel build.gradle e poi get (ovviamente) a tempo di costruzione. Proprio come una macro di pre-processre in C / C ++ … Un esempio di dichiarazione sarebbe qualcosa di simile …: android { debug { A_VAR_RETRIEVABLE_IN_JAVA = 42 } release […]

Errore: l'esecuzione non è rioutput per l'attività ': app: transformClassesWithDexForDebug'

L'errore Errore: l'esecuzione non è rioutput per l'attività ': app: transformClassesWithDexForDebug'. com.android.build.transform.api.TransformException: com.android.ide.common.process.ProcessException: org.gradle.process.internal.ExecException: process 'command' / usr / lib / jvm / java-8-oracle / bin / java '' terminato con valore di output zero La mia apple file gradle: apply plugin: 'com.android.application' apply plugin: 'com.google.gms.google-services' android { compileSdkVersion 23 buildToolsVersion "23.0.1" defaultConfig { applicationId […]

Modifica del livello di API Android Studio

Voglio cambiare la versione SDK minima in Android Studio da API 12 all'API 14. Ho provato a cambiarlo nel file manifesto, <uses-sdk android:minSdkVersion="14" android:targetSdkVersion="18" /> e ribuild il progetto, ma ho ancora l'IDE di Android Studio che lancia alcuni errori. Presumo che devo impostare il min SDK in 'properties; del progetto' o qualcosa di simile […]

Imansible risolvere: com.google.firebase: firebase-core: 11.2.0

Ho riscontrato molteplici problemi "Imansible risolvere" durante la sincronizzazione del mio progetto. Sono tutti firebase e giochi-servizi correlati. Ho fatto in modo che siano tutti uguali (11.2.0). Ho anche controllato e la versione più recente per entrambi è 11.2.0. Inoltre, tutte le altre risposte a domande simili implicano l'aggiornamento dei servizi di Google Play e […]

Aggiunta di file locali .aar a Gradle utilizzando "flatDirs" non funziona

Sono a conoscenza di questa domanda: Aggiunta di file locali .aar alla mia gradella build ma la soluzione non funziona per me. Ho provato ad aggiungere questa dichiarazione al livello superiore del mio file build.gradle : repositories { mavenCentral() flatDir { dirs 'libs' } } Ho anche messo il file slidingmenu.aar in /libs e ho […]

L'Android è un fan Android di Google, tutto su telefoni Android, Android Wear, Android Dev e applicazioni Android Games e così via.