Tag: gradle

com.android.build.api.transform.TransformException: com.android.builder.packaging.DuplicateFileException: file duplicati

Io uso la versione android studio 2.0. Io uso la gradella per build il programma, prendi questa domanda: So che questa domanda nello studio Android 0.7version ha la stessa domanda. Vedo i file duplicati Link copiati (Android Studio 0.4.0) Ma seguo questo modo: Ma questo metodo non funziona per me! Potresti aiutarmi? Ti sto aspettando!

Come funziona la nuova applicazioneId in build.gradle?

Google ha rilasciato la versione 0.11 del plugin di Android Gradle. Le note di rilascio contengono le seguenti informazioni: Una delle modifiche visibili dall'utente in 0.11 è che abbiamo deprecato le impostazioni packageName e packageNameSuffix e le abbiamo rinominate in applicationId e applicationIdSuffix. Lo scopo di questo è quello di rendere chiaro che questo ID […]

Integrazione manifesta di Gradley di Google: sovrascrive l'attributo "usa-permesso" proveniente da una libreria

Per la mia applicazione che sto sviluppando con l'ultimo Android Studio sto utilizzando queste dependencies all'interno del suo file gradle: dependencies { compile 'com.android.support:support-v4:21.0.+' compile 'com.helpshift:android-aar:3.7.1' } La com.helpshift:android-aar:3.7.1 libreria richiede la seguente authorization per una funzionalità che non utilizzo nella mia applicazione principale: <uses-permission android:name="android.permission.WRITE_EXTERNAL_STORAGE" /> Come descritto qui e qui posso ignorare gli […]

Android – Il prefisso "xmlns" non può essere vincolato a qualsiasi spazio dei nomi esplicitamente; né il namespace per "xmlns" può essere associato esplicitamente a qualsiasi prefisso

Qualcuno ha ottenuto questo problema di nomi "xmlns" (vedi sotto)? Non riesco più a build il mio progetto di lavoro. All'inizio ho pensato che fosse il mio branch di git, quindi ho passato all'origine sviluppare e dominare i rami – la questione persiste. Ho pulito e ricostruito il mio problema di progetto persiste. Ho pulito […]

Passare i parametri P a gradle da studio android

C'è una funzionalità all'interno dello studio android per fare cose come questo. Fondamentalmente il mio script di gradle legge il parametro denominato versione in base alla quale imposta la versione di dipendenza di una certa libreria. Così quando faccio gradlew -Pversion = '1.2.3' ho questa string all'interno gradle. Ma questo funziona solo se invoco gradle […]

Utilizzare diverse risorse per diversi sapori di applicazione utilizzando graduale

Ho un'applicazione androida e vorrei avere diversi sapori. In particolare vorrei avere 2 sapori e per ciascun sapore utilizzare diverse stringhe (diversi file strings.xml ) e forse alcune icone diverse. Ho provato a creare due cartelle nella cartella principale del progetto: flav1 e flav2 e flav2 utilizzato il seguente build.gradle android { compileSdkVersion "Google Inc.:Google […]

AndroidStudio / Gradle con powermock

Non sono riuscito a trovare informazioni su come impostare powermock con Android Studio / Gradle. Tutto quello che ho provato ha portto a build eccezioni. Qualcuno potrebbe mostrare un modo corretto per farlo? Grazie.

Dipendenze di IntelliJ e Android Gradle – incapaci di trovare il module

Ho la seguente struttura di directory: D:\PROJECT +—javaGradleProject1 +—javaGradleProject2 +—javaGradleProject3 \—AndroidProject | build.gradle | settings.gradle \—AndroidModule build.gradle Il module Android dipende da tutti i progetti di gradi java che sono allo stesso livello nella directory principale di AndroidProject. In AndroidProject / settings.gradle ho: include ':AndroidModule' include 'javaGradleProject1' project(':javaGradleProject1').projectDir = new File(rootDir, '../javaGradleProject1') include 'javaGradleProject2' project(':javaGradleProject2').projectDir […]

Android Studio 3.0 Beta 1: Imansible risolvere: com.android.support:multidex:1.0.2

Dopo la migrazione da Android Studio 3.0 (Canary 5) a Android Studio 3.0 (Beta 1) e spostandosi all'ultimo gradle, vale a dire 'com.android.tools.build:gradle:3.0.0-beta1' Quando provo a gradelare la sincronizzazione, errore indica di seguito. Failed to resolve: com.android.support:multidex:1.0.2 Failed to resolve: com.android.support:multidex-instrumentation:1.0.2 Controllo su Android Studio 3.0 Canary 9 – Imansible risolvere i pacchetti , non […]

È stata trovata la configuration di Gradley JDK non valida?

Sono molto nuovo in Android Studio . Ho un problema con gradle . dice, Error:Invalid Gradle JDK configuration found. Platform SDK does not point to valid `JDK` `(C:/Program Files/Java/jdk1.8.0_20)`. Consult IDE log for more details (Help | Show Log) allora cosa devo fare per risolvere questo problema?

L'Android è un fan Android di Google, tutto su telefoni Android, Android Wear, Android Dev e applicazioni Android Games e così via.