come aggiornare il plugin com.android.application?

Ho ricevuto questo messaggio:

Plugin is too old, please update to a more recent version, or set ANDROID_DAILY_OVERRIDE environment variable to "a9d6c794295e89d95704157e2ed8fd55ffd2765c" 

e:

  • come avere l'elemento di elenco avanzato in listview
  • È meglio utilizzare AsyncTask o Service per caricare un file in background?
  • Come utilizzi l'API Android Volley?
  • Ricerca full text di Android e ListAdapter
  • Crea adattatore personale in Android?
  • Compatibilità vettoriale Android
  •  C:\path\mobile\build.gradle Error:(1) A problem occurred evaluating project ':mobile'. Failed to apply plugin [id 'com.android.application'] Could not create plugin of type 'AppPlugin'. 

    file build.gradel superiore:

     buildscript { repositories { jcenter() } dependencies { classpath 'com.android.tools.build:gradle:1.3.0-beta1' classpath 'com.google.gms:google-services:1.3.0-beta1' // NOTE: Do not place your application dependencies here; they belong // in the individual module build.gradle files } } allprojects { repositories { jcenter() } } 

    In sostanza, non so come aggiornare il plugin com.android.application.

    4 Solutions collect form web for “come aggiornare il plugin com.android.application?”

    A quanto pare, le versioni beta del plugin di Gradle per Android scadono. AFAIK, questo non è un comportmento documentato. Adesso, l'unico modo per sapere di sapere cosa sarà l'ultima release beta sarà controllare il http://tools.android.com/tech-docs/new-build-system . In realtà mostra un beta3 ; Avevo pensato che l'ultima era beta2 .

    Ho solo bisogno di cambiare la linea

    classpath 'com.android.tools.build:gradle:2.0.0-alpha1'

    a

    classpath 'com.android.tools.build:gradle:2.0.0-alpha3' in top build.gradle

    Sapevo che era alpha3 causa dell'ultima nota di rilascio http://tools.android.com/tech-docs/new-build-system .

    Ero anche affrontato lo stesso problema.

    Ho cambiato la versione gradle da

     classpath 'com.android.tools.build:gradle:2.0.0-alpha1' 

    a

     classpath 'com.android.tools.build:gradle:2.1.0-rc1' 

    Dato che Android Studio viene aggiornato, il 22 aprile 2016 è l'ultima versione di gradle.

    Dal 11 maggio la versione stabile stabile è

     classpath 'com.android.tools.build:gradle:2.1.1' 

    Trovare la versione più recente del sistema di generazione da [sito del progetto studio di Android] [1]

    [1]: http://tools.android.com/tech-docs/new-build-system e aggiornare il classpath di conseguenza. Dal 2016/6/23, è 2.2.0-alfa4 . Così, rendi classpath 'com.android.tools.build:gradle:2.2.0-alpha4 sul file build.gradle .

    L'Android è un fan Android di Google, tutto su telefoni Android, Android Wear, Android Dev e applicazioni Android Games e così via.