Come posso impostare la versione gradel in Android studio 1.3?

Ho aggiornato lo studio Android alla versione 1.3. Nel mio progetto devo usare la versione gradle versione 2.2.1 e la versione 1.0.0 di android gradle plugin. Come posso impostare lo studio android per utilizzare la versione 2.2.1 gradle automaticamente?

Ho impostato le properties; del wrapper gradle in 2.2.1 e nella struttura del progetto mostra anche che sta utilizzando la versione gradi 2.2.1

  • Il modo migliore per avere versato e versione gratuita di un'applicazione Android
  • Nascondere le properties; all'interno di un tag in Ksoap2
  • Come aggiungere l'icona di 3 righe nell'angolo superiore sinistro di Android DrawerLayout
  • Errore: Stato {statusCode = DEVELOPER_ERROR, risoluzione = null}
  • android BluetoothChat utilizza l'invio di methods di ricezione da un'altra class
  • android - "Il ricevitore esportto non richiede l'authorization" sui destinatari destinati a ricevere dai servizi di sistema
  • gradle-wrapper.properties

    #Wed Apr 10 15:27:10 PDT 2013 distributionBase=GRADLE_USER_HOME distributionPath=wrapper/dists zipStoreBase=GRADLE_USER_HOME zipStorePath=wrapper/dists distributionUrl=https\://services.gradle.org/distributions/gradle2.2.1-all.zip 

    Produzione:

    Errore: Gradel 2.4 richiede Android Gradle plugin 1.2.0 (o più nuovo) ma il progetto sta utilizzando la versione 1.0.0. Utilizza l'applicazione Android Gradle plugin 1.2.0 o la versione plugin Fix e il progetto di sincronizzazione

    Voglio usare Gradle 2.2.1 ma continuo a saltare a 2.4

  • Email con allegato
  • android aspetta asynctask per finire
  • Vantaggi dell'utilizzo di Bundle invece di intent putExtra () diretto in Android
  • ExoPlayer e comandi start / pause / seekTo
  • Come aggiornare PreferenceActivity per mostrare le modifiche nelle impostazioni?
  • IntelliJ IDEA - Non può build nulla, sempre get "pacchetto R non esiste"
  • 3 Solutions collect form web for “Come posso impostare la versione gradel in Android studio 1.3?”

    Stavo ricevendo lo stesso errore in Android Studio e risulta che Android Studio stava puntando alla propria versione di gradle invece che al mio wrapper di progetto.

    Per Windows Android Studio, vai in File> Impostazioni> "Costruisci, Esecuzione, Distribuzione"> "Strumenti di generazione"> Gradel e cambialo in "Utilizza il wrapper di default graded (consigliato)".

    Questo mi ha fissato senza wherer cambiare le dependencies. Speriamo che questo è tutto il necessario.

    Nel build.gradle del tuo progetto (NON il module dell'applicazione) assicurati che la sua utilità android gradle costruisca strumenti di 1.2.0 o superiore. Quindi, nel tuo file, la sezione di dipendenza dovrebbe sembrare qualcosa di simile:

     dependencies { classpath 'com.android.tools.build:gradle:1.3.+' } 

    Se vuoi sempre i più recenti strumenti di costruzione di gradle, cambialo in:

     dependencies { classpath 'com.android.tools.build:gradle:+' } 

    Dalla OP:

    Questo dosnt risolve il mio problema. Ho bisogno della versione plugin utente 'com.android.tools.build:gradle:1.0.0' nel mio progetto, quindi ho impostato questo nel mio file build.gradle del progetto. Il problema che ho è che questo ha funzionato con l'uso di gradle 2.2.1 ma da quando android Studio 1.3 utilizza gradle 2.4 non funziona. Quindi devo in qualche modo get studio android per usare la versione gradi 2.2.1 in modo da poter utilizzare gradle plugin 1.0.0.

    Si consiglia di utilizzare la più recente Gradle per cui Android Studio avverte di aggiornarlo alla versione più recente.

    Perché si desidera tornare alla versione precedente?

    Nota: se pensi che la versione più recente creerà qualsiasi complicazione nel codice stabile, ti assicuri che non causerà alcun danno al codice. E non si può get alcun vantaggio extra dalla versione precedente. Nuova versione significa qualcosa di più efficiente e privo di bug.

    L'Android è un fan Android di Google, tutto su telefoni Android, Android Wear, Android Dev e applicazioni Android Games e così via.