Errore Android Studio

Sono nuovo a Android e sto utilizzando l'Android Studio. Ho creato un nuovo progetto solo per mostrare il Hello World! ma non posso far funzionare l'AVD a causa di questo errore: errore [INSTALL_FAILED_OLDER_SDK].

Ho già cercato la risposta e so che è qualcosa sul build.gradle e sul minSdkVersion ma tutte le risposte hanno funzionato per me.

  • Android NDK trabocca la tabella di riferimento locale dalvik JNI
  • Come ignorare l'accento nella query SQLite (Android)
  • JSONParser non può essere risolto a un tipo
  • Aggiungere il layout personalizzato a ActionBar / Toolbar senza margini
  • Come faccio a fare uno scanner di impronte digitali USB collegato a un telefono cellulare / tablet funziona correttamente?
  • Come posizionare Views in RelativeLayout in modo programmato?
  • Questo è il mio AndroidManifest.xml:

    <?xml version="1.0" encoding="utf-8"?> <manifest xmlns:android="http://schemas.android.com/apk/res/android" package="com.example.scoelli.test" > <application android:allowBackup="true" android:icon="@drawable/ic_launcher" android:label="@string/app_name" android:theme="@style/AppTheme" > <activity android:name=".MyActivity" android:label="@string/app_name" > <intent-filter> <action android:name="android.intent.action.MAIN" /> <category android:name="android.intent.category.LAUNCHER" /> </intent-filter> </activity> </application> </manifest> 

    E questo è il mio build.gradle:

     apply plugin: 'com.android.application' android { compileSdkVersion 'android-L' buildToolsVersion "20.0.0" defaultConfig { applicationId "com.example.scoelli.test" minSdkVersion 8 targetSdkVersion 'L' versionCode 1 versionName "1.0" } buildTypes { release { runProguard false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro' } } } dependencies { compile fileTree(dir: 'libs', include: ['*.jar']) } 

    Mi piacerebbe non solo la risposta, ma la spiegazione.

    Grazie!

  • savedInstanceState è sempre nullo
  • Libreria Android Volley: dobbiamo sempre ripetere Response.Listener e Response.ErrorListener
  • Android: OnTouch, MotionEvent.ACTION_MOVE non è riconosciuto?
  • Inserire ContentProvider () sempre sul thread UI?
  • Qual è il punto di setArguments?
  • Libreria C # .dll nell'applicazione Android
  • 4 Solutions collect form web for “Errore Android Studio”

    A less che non si conosca che si desidera utilizzare l'anteprima degli sviluppatori di Android L con la tua applicazione, non bersagli e compilati con esso. È ancora molto un rilascio di anteprima e sembra che le applicazioni che mirano e compilano per l'anteprima causano questo errore con qualsiasi dispositivo non-L.

    Aggiorna queste righe nel tuo build.gradle per rispettare l'ultima release stabile (Android 4.4, API 19):

     android { compileSdkVersion 19 defaultConfig { targetSdkVersion 19 } } 

    Ho risolto questo problema. Ho appena modificato il compileSdkVersion da android_L a 19 per mirare il mio nexus 4.4.4.

     buildscript { repositories { jcenter() } dependencies { classpath 'com.android.tools.build:gradle:0.12.2' } } apply plugin: 'com.android.application' repositories { jcenter() } android { **compileSdkVersion 'android-L'** modified to 19 buildToolsVersion "20.0.0" defaultConfig { applicationId "com.antwei.uiframework.ui" minSdkVersion 14 targetSdkVersion 'L' versionCode 1 versionName "1.0" } buildTypes { release { runProguard false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro' } } } dependencies { compile fileTree(dir: 'libs', include: ['*.jar']) **compile 'com.android.support:support-v4:21.+'** modified to compile 'com.android.support:support-v4:20.0.0' } 

    come modificare il valore da ide. select il file-> Struttura del progetto -> Faceti -> android-gradle e quindi modificato la versione di compilazione Sdk da android_L a 19

    mi dispiace non ho abbastanza reputazione per aggiungere foto

    Penso che progetti con

      compileSdkVersion 'android-L' 

    non può essere installato in altre versioni Android adesso. Potrei essere sbagliato, ma se non stai facendo qualcosa di specifico per l'SDK L preview, basta impostare la versione di compilazione a uno di quelli ufficiali. Lo stesso vale per il targetSdk.

    È ansible scegliere quelli nella procedura guidata Crea progetto.

    Se si verifica questo errore durante la compilazione di un'applicazione mobile Adobe AIR, correggere correttamente "minSdkVersion" questa row nel file xml del descrittore delle applicazioni:

     <uses-sdk android:minSdkVersion="13" android:targetSdkVersion="15"></uses-sdk> 
    L'Android è un fan Android di Google, tutto su telefoni Android, Android Wear, Android Dev e applicazioni Android Games e così via.