Errore durante la creazione di un progetto su Android Studio 2.3

Ho aggiornato Android Studio da 2,2 a 2,3 e quando creo un nuovo progetto Android con un'attività di navigazione ho due errori:

Error:java.util.concurrent.ExecutionException: java.lang.RuntimeException: AAPT process not ready to receive commands Error:Execution failed for task ':app:mergeDebugResources'. > Error: java.util.concurrent.ExecutionException: java.lang.RuntimeException: AAPT process not ready to receive commands 

Quando avevo la versione più vecchia ho risolto il problema cambiando il valore di buildToolsVersion nel file build.gradle a 23.0.3 anziché 25.0.0.

  • Passaggio di arrayslist in intento da un'attività all'altra
  • Integrazione di NDK nello studio Android
  • Impostazione predefinita della videocamera non terminata Premere il tasto OK
  • Come posso tranquillamente (indirettamente) interrogare un database postgresql in android?
  • Colonna mancante sqlite di Android
  • ricevitore di trasmissione per chiamata persa in android
  • Nella nuova versione faccio la stessa modifica e ho ottenuto il seguente errore:

     Gradle Sync Issues Error:Error:The SDK Build Tools revision (23.0.3) is too low for project ':app'. Minimum required is 25.0.0 Update Build Tools version and sync project 

    Ma questo non è il cambiamento che faccio. Devo inoltre cambiare la versione delle librerie di supporto Android sulle dependencies:

     compile 'com.android.support:appcompat-v7:23.1.1' compile 'com.android.support:design:23.1.1' 

    Questi errori vengono visualizzati su Debian Linux. Ho un collega che lavora su Windows e può creare nuovi progetti utilizzando la versione Android Studio 2.3.

    Come posso risolvere questi errori?

    Grazie.

  • Come creare un menu sidebar
  • android achartengine: cercare di esportre il grafico come exception di immagini
  • Android Studio crea un model di progetto per nuovi progetti
  • Purtroppo l'applicazione si è arrestata - android.os.NetworkOnMainThreadException
  • Qual è lo strumento "dumpsys" dello shell Android ADB e quali sono i suoi vantaggi?
  • quando viene selezionato il text, viene visualizzato il menu di copia e incolla personalizzato
  • 4 Solutions collect form web for “Errore durante la creazione di un progetto su Android Studio 2.3”

    Vai a File->Project Structure... (o premi Ctrl+Shift+Alt+S ).

    Nella barra laterale sinistra, fare clic su Project (in SDK Location ) e modificare la Gradle version (a qualcosa di simile a 3.2 ) e modificare la Android Plugin Version (a qualcosa di simile a 2.2.0 o 2.2.2 ).

    Questo riprenderà il tuo AndroidStudio prima dell'aggiornamento di 2.3 modo da poter continuare a sviluppare fino a quando Google non sarà in grado di risolvere tutto ciò che è sbagliato con 2.3 . Poi puoi anche cambiare la tua buildToolsVersion su 23.0.3 per evitare di get il file

     Error:Error:The SDK Build Tools revision (23.0.3) is too low for project ':app' 

    errore, e il tuo progetto dovrebbe ricompilare correttamente.

    In te gradle, lo strumento di costruzione deve essere> = 25

     android { compileSdkVersion 25 buildToolsVersion '25' 

    E si modifica il supporto a 25.2.0 (ora è il più recente)

     compile 'com.android.support:appcompat-v7:25.2.0' compile 'com.android.support:design:25.2.0' 

    caricare Android SDK Build Tools versione 25.0.1 in android Studio 2.3 Struttura del progetto -> Proprietà -> Build Tools versione 25.0.1

    Dopo aver fatto questo progetto viene costruito senza alcun errore.

    Questo problema stava accadendo sul mio telefono, che è un telefono Xiaomi in esecuzione su Miui 8. Dopo aver distriggersto le ottimizzazioni di Miui sulle impostazioni dello sviluppatore, riavviando il telefono cellulare ricompilando l'applicazione che ha funzionato.

    https://stackoverflow.com/a/42636693/2885194

    L'Android è un fan Android di Google, tutto su telefoni Android, Android Wear, Android Dev e applicazioni Android Games e così via.