Gradle versione 1.10 è richiesta. La versione corrente è 2.2.1. in android

Ho avuto un progetto Android sviluppato con Android Studio e ho cercato di importrla e di eseguirla sul mio Android Studio, ma di fronte all'errore di seguito quando ho cercato di sincronizzare il progetto

Failed to sync Gradle project 'project-android' Error:Gradle version 1.10 is required. Current version is 2.2.1. If using the gradle wrapper, try editing the distributionUrl in /Users/username/apps/android/project-android/gradle/wrapper/gradle-wrapper.properties to gradle-1.10-all.zip. Please fix the project's Gradle settings in Gradle settings 

gradle-wrapper.properties

  • gridview con image e text android
  • Come creare un'applicazione Android con l'interface utente ICS che funziona con panpepato e Froyo?
  • maven android plugin con libreria di supporto android v7
  • Creazione di un'altra AsyncTask all'interno di doInBackground
  • differenza tra rawquery e execSQL nel database sqlite android
  • Come aprire il popup di authorization in miui?
  •  distributionBase=GRADLE_USER_HOME distributionPath=wrapper/dists zipStoreBase=GRADLE_USER_HOME zipStorePath=wrapper/dists distributionUrl=http\://services.gradle.org/distributions/gradle-1.10-all.zip 

    build.gradle

     buildscript { repositories { mavenCentral() } dependencies { classpath 'com.android.tools.build:gradle:0.9.+' } } allprojects { repositories { mavenCentral() } } Android Studio Version : 1.0.1 

    Quindi, come risolvere l'errore di cui sopra

    Modifica

    Dopo aver cambiato le righe come indicato da @Grabiele ho ottenuto i seguenti errori

     Error:(22, 0) Gradle DSL method not found: 'runProguard()' Possible causes: The project 'project-android' may be using a version of Gradle that does not contain the method. The build file may be missing a Gradle plugin. 

    Questa è la linea che ho avuto nel file app/build.gradle

      buildTypes { release { runProguard false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.txt' } } 

  • Android NDK STL c ++ _ condiviso con risultati LIBCXX_FORCE_REBUILD in std :: stringstream NOP
  • Come rilevare in modo programmato se un'app-app support Android Wear?
  • Collegamento di due istanze di emulatore in Android
  • Come si può rilevare se il dispositivo è radicato nell'applicazione?
  • Android HTTPUrlConnection: come impostare i dati post in http body?
  • Come posso modificare l'allineamento iniziale di Android Snackbar dal basso verso l'alto?
  • 2 Solutions collect form web for “Gradle versione 1.10 è richiesta. La versione corrente è 2.2.1. in android”

    Devi aggiornare:

    • plugin gradle per Android
    • versione gradel
    • syntax proguard

    Plugin Gradle per Android

    Devi cambiare questa row in build.gradle :

     classpath 'com.android.tools.build:gradle:0.9.+' 

    in

     classpath 'com.android.tools.build:gradle:1.1.+' 

    Versione di Gradle

    Modificare questa row in gradle-wrapper.properties

     distributionUrl=http\://services.gradle.org/distributions/gradle-1.10-all.zip 

    in

     distributionUrl=http\://services.gradle.org/distributions/gradle-2.2.1-all.zip 

    Su proguard devi cambiare questa row nel tuo build.gradle

     buildTypes { release { runProguard false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.txt' } } 

    In

     buildTypes { release { minifyEnabled false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.txt' } } 

    Oltre alla risposta @Gabriele

    dovresti cambiare

     runProguard false 

    a

     minifyEnabled false 
    L'Android è un fan Android di Google, tutto su telefoni Android, Android Wear, Android Dev e applicazioni Android Games e così via.