java.lang.NoSuchMethodError: Nessun metodo statico setOnApplyWindowInsetsListener

Ho aggiornato il mio studio android a 2.1.3. E adesso sto ottenendo l'errore

java.lang.NoSuchMethodError: No static method setOnApplyWindowInsetsListener(Landroid/view/View;Landroid/support/v4/view/OnApplyWindowInsetsListener;)V in class Landroid/support/v4/view/ViewCompatLollipop; or its super classs (declaration of 'android.support.v4.view.ViewCompatLollipop' appears in /data/data/com.restroshop.restroowner/files/instant-run/dex/slice-internal_impl-24.2.0_7c318f8d2adb03d07a9def5d35a14e39204ecef2-classs.dex) at android.support.v4.view.ViewCompat$LollipopViewCompatImpl.setOnApplyWindowInsetsListener(ViewCompat.java:1619) at android.support.v4.view.ViewCompat.setOnApplyWindowInsetsListener(ViewCompat.java:2924) at android.support.v7.app.AppCompatDelegateImplV7.createSubDecor(AppCompatDelegateImplV7.java:425) at android.support.v7.app.AppCompatDelegateImplV7.ensureSubDecor(AppCompatDelegateImplV7.java:312) at android.support.v7.app.AppCompatDelegateImplV7.setContentView(AppCompatDelegateImplV7.java:277) at android.support.v7.app.AppCompatActivity.setContentView(AppCompatActivity.java:140) at com.restroshop.restroowner.splash.SplashScreen.onCreate(SplashScreen.java:65) at android.app.Activity.performCreate(Activity.java:6033) at android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:1106) at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2278) at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:2387) at android.app.ActivityThread.access$800(ActivityThread.java:151) at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1303) at android.os.Handler.dispatchMessage(Handler.java:102) at android.os.Looper.loop(Looper.java:135) at android.app.ActivityThread.main(ActivityThread.java:5254) at java.lang.reflect.Method.invoke(Native Method) at java.lang.reflect.Method.invoke(Method.java:372) at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:902) 

in linea setContentView(R.layout.activity_splash_screen);

  • Come possiamo aprire i collegamenti di TextView in Webview
  • Ottenere l'attuale anno e mese risultando strano risultati
  • Non è ansible inserire ore totali in MySQL da Android
  • Perché faccio a "Non riescono a rimbalzare per digitare" quando trasforma JSON da Firebase in oggetti Java?
  • Spinner - concentrarsi sul primo elemento
  • come faccio a estrarre il text da un xml nidificato usando xmlpullparser in android?
  • Il mio snippet di codice è

     public class SplashScreen extends AppCompatActivity { @Override protected void onCreate(Bundle savedInstanceState) { super.onCreate(savedInstanceState); setContentView(R.layout.activity_splash_screen); // this line giving error } 

    Non ho idea di cosa sia andato storto.

  • Come aprire un PDF memorizzato nella memory interna
  • android visualizza l'object json a listview
  • Come modificare la dimensione di text in data-picker?
  • Do 'Chrome Apps for Mobile' utilizza la visualizzazione web nativa su each piattaforma?
  • Performance Disegnabili Disegno di Android?
  • Come get l'elenco delle applicazioni installate con Unity3D?
  • 2 Solutions collect form web for “java.lang.NoSuchMethodError: Nessun metodo statico setOnApplyWindowInsetsListener”

    Ho aggiornato il mio studio android a 2.1.3. E adesso sto ottenendo l'errore

    So anche che soffre con lo stesso problema. Ma sono stato risolto come il seguente modo.

    La ragione di questa exception è AppcompatActivity derivata dalla libreria v7. quindi dobbiamo fornire una biblioteca adeguata basata sul tuo gradle e SDK.

    1. dovrebbe aggiornare anche le librerie di dipendenza.
    2. Fare clic con il button destro del mouse sul progetto nella struttura del progetto -> select Apri impostazioni module e select scheda dependencies -> Modulo libreria -> quindi digitare quale libreria si desidera aggiungere al progetto. Mostra le ultime librerie basate sulla versione aggiornata di gradle, quindi seleziona quella più recente e rimuove quella esistente.

    Ad esempio Nel mio progetto la versione "appcompat-v7" è 23.4.0, quindi sono stato cambiato a 24.2.0.

    Ho avuto questo errore a causa della versione multipla della stessa libreria.

     compile 'com.android.support:appcompat-v7:23.4.0' compile 'com.jakewharton:butterknife:8.5.1' 

    Il butterknife stava aggiungendo la nuova versione del appcombat lib. Ho controllato utilizzando

     ./gradlew -q dependencies app:dependencies 

    Il modo in cui gradile funziona automaticamente aggiorna la libreria a una nuova versione della libreria, se disponibile. Così ho aggiunto il seguente codice

     compile('com.jakewharton:butterknife:8.5.1') { exclude module: 'appcompat-v7' exclude group: 'com.android.support' } 

    Ha funzionato bene dopo di che.

    L'Android è un fan Android di Google, tutto su telefoni Android, Android Wear, Android Dev e applicazioni Android Games e così via.