"Nessuna image di sistema installata per questo target" anche se l'image è installata

SDK Manager

Quindi sto cercando di creare un simulatore AVD e continuo a ricevere l'errore "Nessuna image del sistema installato per questo target" quando si cerca di creare un sistema 4.2.2 anche se l'image è installata (vedere l'image di SDK Manager).

  • Elenco personalizzato facendo clic con le caselle di controllo
  • Il frammento di Android sul progetto ha richiamato il cambiamento di tabulazione
  • Spostare il progetto Android / Eclipse a un nuovo PC
  • Eclipse: "Imansible risolvere l'importzione java.io"
  • L'azione ActionBar di Android ToolLayout di Switch causa il salto del text quando si preme il menu
  • Come aprire PDF in Android
  • Il mio sistema è x64, che fa la differenza?

    Errore di Eclipse

  • I dati di GPS errati di GPS di Android sulla query
  • Tastiera Android - inizio minuscolo
  • Come impostare la trasparenza di un file xml Android di background
  • CLI su DalvikVM fallisce su JNI lib
  • Uso della tascaffinità android
  • Android - Ruotare un ImageView con il dito muove altre viste in giro
  • 8 Solutions collect form web for “"Nessuna image di sistema installata per questo target" anche se l'image è installata”

    Dopo l'aggiornamento SDK ho avuto gli stessi problemi con l'API Livello 19 e nel mio caso riavviando l'eclipse non l'ho risolto.

    Per qualche motivo, nella directory sdk/system-images/android-19 , le sottocartelle con immagini di sistema (armeabi-v7a e x86) sono state collocate nella directory "default" . Li ho appena spostati nella directory android-19 (se l'eclipse è in esecuzione contemporaneamente, dovrai riavviarlo).

    Devi solo riavviare gli strumenti. Ho visto questo bug prima. Le immagini installate appropriate verranno visualizzate dopo il riavvio.

    Puoi anche provare a aggiornare all'interno del menu 'Pacchetti', ma la cosa più semplice è riavviare gli strumenti.

    Goto sdk \ system-images e apri la cartella dell'attuale API che state usando (ad esempio , la cartella android-19 nel tuo caso). Ora troverai una cartella denominata "predefinita" , aprila e vedrai la cartella denominata 'armeabi-v7a' o qualsiasi image di sistema che hai installato. Ora spostare la cartella 'armeabi-v7a' nella directory sdk \ system-images … cioè semplicemente fuori dalla cartella 'default' .

    Questo è tutto. Ho avuto lo stesso problema e questo metodo ha funzionato per me. : D

    Ho riavviato eclipse.it elaborato per me, il problema è risolto.

    Ho avuto questo stesso problema. Il mio problema è stato risolto uccidendo l'eclipse (Command + Q) perché sono un utente Mac. Quindi, se sei sotto un altro sistema operativo assicurati di uccidere il process di Eclipse e rilanciarlo.

    Molto semplice. Ho riavviato Eclipse, ho ricaricato il mio progetto e quando crei un nuovo emulatore, il problema è andato

    Trovato questo thread quando ho fatto una ricerca su Google per lo stesso errore.

    Quindi ho voluto aggiungere che se qualcuno viene in questo thread, ma stai utilizzando Android Studio . Devi solo riavviare Android Studio. Ho fatto e ora posso vedere quello che ho installato.

    immettere qui la descrizione dell'immagine

    Assicurarsi di avere diritti su tutti i file della directory android-sdk-linux utilizzando:

     sudo chown $USER -R ./android-sdk-linux 
    L'Android è un fan Android di Google, tutto su telefoni Android, Android Wear, Android Dev e applicazioni Android Games e così via.